Jump to content
VobaTrader

Excel ... If...then...-Abfragen ?

Recommended Posts

VobaTrader
Posted

Hi Leute

 

 

Suche habe ich bemüht ,leider aber nix passendes gefunden.

 

 

Es geht um folgendes:

 

Bastel mir grade eine Excel-Datei zusammen wo ich verschiedene Kennzahlen errechnen lasse.

 

 

Wo ich nun aber an meine Grenzen stoße ist die Möglichkeit den Kennzahlen bestimmte Noten zuzuordnen.

 

Bsp: Eigenkapitalquote > 40% = Note 2 - Eigenkapitalquote > 50% = Note 1 usw.

 

 

Gibt es da bestimmte Abfragen die ich benutzen kann ?

 

Und noch eins: Gibt es auch die Möglichkeit bei bestimmten Kennzahlen automatisch das Kästchen daneben Grün , Orange oder Rot anmalen zu lassen. Je Nachdem wie gut die Kennzahl ist.

 

 

Hoffe auf eure Hilfe :)

 

Benutze OpenOffice 2.4

 

Danke schonmal

 

 

Greetz

Share this post


Link to post
Dork
Posted · Edited by Dork

Eigenkapitalquote > 40% = Note 2 - Eigenkapitalquote > 50% = Note 1

 

=wenn("EKQ">50;1;wenn("EKQ">40;2;wenn("EKQ">30;3;wenn("EKQ">20;4;5))))

 

in " " sollte der Verweis auf die Quellzelle sein z.B. B4 oder so

 

Zum Verständnis:

Ergebnis=wenn(die EKQ>50; dann 1; sonst nächste Überprüfung)

 

 

Zum zweiten Problem:

Unter dem Reiter "Format" gibt es "Bedingte Formatierung". Das sollte Dir weiterhelfen.

 

Achja...Du arbeitest mit OpenOffice...habs jetzt für Excel gelöst...hm..evtl. klappts ja trotzdem..

Share this post


Link to post
boRn
Posted
Und noch eins: Gibt es auch die Möglichkeit bei bestimmten Kennzahlen automatisch das Kästchen daneben Grün , Orange oder Rot anmalen zu lassen. Je Nachdem wie gut die Kennzahl ist.

Ob es das bei OpenOffice auch gibt weiss ich nicht, aber bei Excel heisst das "bedingte Formatierung" unter Format -> bedingte Formatierung. Da kannst du einstellen, welche Farbe ein Feld haben soll, wenn eine Bed. erfüllt ist.

 

mfg

Chris

Share this post


Link to post
muisyle
Posted · Edited by muisyle

Openoffice hab ich net aber in excel kannst du hiermit

 

=WENN(C13>40%;4;WENN(C13>30%;3;WENN(C13>20%;2)))

 

hoffentlich was anfangen.

 

> 40% = 4

> 30% = 3

> 20% = 2

 

Edit: Argh zu lahm :D

Share this post


Link to post
Sapine
Posted

Das funktioniert beides bei open office 2.3 genauso wie bei Excel.

Bedingte Formatierung kenne ich aber nur, dass die Zelle selbst formatiert wird. Eine bedingte Formatierung der Nachbarzelle ist mir nicht bekannt weder bei Excel noch bei open office.

Share this post


Link to post
boRn
Posted
Das funktioniert beides bei open office 2.3 genauso wie bei Excel.

Bedingte Formatierung kenne ich aber nur, dass die Zelle selbst formatiert wird. Eine bedingte Formatierung der Nachbarzelle ist mir nicht bekannt weder bei Excel noch bei open office.

Kannst du ja aber über die Nebenzelle bedingen. Also wenn die Nebenzelle = 1 dann die Nachbarzelle = grün...

 

mfg

Chris

Share this post


Link to post
Sapine
Posted

Tatsächlich statt auf Zielwert kann man auch auf Formel gehen und dann geht natürlich alles - wieder was gelernt. :)

Share this post


Link to post
Arkad
Posted

Würde anstatt einer IF-WENN-Formel nicht auch ein SVerweis gehen? Wäre halt eine zusätzliche Matrix für notwendig. Weiß das jemand auf die Schnelle?

Share this post


Link to post
Sapine
Posted · Edited by Sapine
Würde anstatt einer IF-WENN-Formel nicht auch ein SVerweis gehen? Wäre halt eine zusätzliche Matrix für notwendig. Weiß das jemand auf die Schnelle?

klar geht auch, aber warum kompliziert wenn auch einfach möglich?

Share this post


Link to post
Arkad
Posted
klar geht auch

Probiere ich mich heute Abend mal dran :thumbsup:

Share this post


Link to post
Wave XXL
Posted

ich würde das an deiner stelle über formeln machen - zumindest mache ich das so :D

 

denn sonst wird es so ungenau wie beim quicktest, bsp ekq 49,9% ergibt dann noch ne 2, während 50% ne 1 gibt - mir war das zumindest nicht genau genug....

 

hab mir dann formeln für jede kennzahl überlegt - bei den kurskennzahlen musst ich halt dann mit logarithmus arbeiten, das war dann etwas komplizierter....musst dann nur noch die grenzen bei 1-6 setzen und fertig ist das ding - wenn du willst kann ich dir mal meine formeln reinschreiben ;)

Share this post


Link to post
VobaTrader
Posted

Vielen Dank an die vielen schnellen Antworten :)

 

hab mir dann formeln für jede kennzahl überlegt - bei den kurskennzahlen musst ich halt dann mit logarithmus arbeiten, das war dann etwas komplizierter....musst dann nur noch die grenzen bei 1-6 setzen und fertig ist das ding - wenn du willst kann ich dir mal meine formeln reinschreiben ;)

 

 

Wave , gerne , werde mich mit euren Anregungen gleich mal beschäftigen , mal schaun wie ich vorankomme :)

Share this post


Link to post
VobaTrader
Posted · Edited by VobaTrader

Leider hab ich ein kleines Problem:

 

 

post-8980-1208343508_thumb.jpg

 

 

Laut der Formel müsste im Fenster eigentlich eine 3 stehen. Egal welche Zahl ich aber in H6 erscheinen lasse , es steht immer die 1 :(

 

Hab ich was falsch eingegeben?

 

P.S: An dem einen kleinen Schreibfehler bei "KH6" liegt es nicht ;)

Share this post


Link to post
Sapine
Posted · Edited by Sapine

Du musst die "" weglassen. Einfach nur H6 statt "H6" in die Formel eingeben.

Hast auch noch nen Schreibfehler vermute ich mal mit KH6 statt H6

 

Würde auch die >10 oder >0 noch abfragen und für den Rest lieber ein "Fehler" ausgeben, als alles in den Topf mit der 5 reinlaufen zu lassen. Dann kannst Du leicht feststellen, ob alles sauber klassifiziert wurde.

Share this post


Link to post
Wishmueller
Posted

yupp... im Printsreen Deiner Formel steht einmal "KH6" und nicht, wie erforderlich, "H6".... ;)

Share this post


Link to post
boRn
Posted

" xx " sagt Excel immer, dass ein Text folgt, der entweder eingegeben worden ist oder ausgegeben werden soll, also bei Zellbezügen keine ""

 

Fang erstmal mit den Basics an, z.B.

=A1+A2 oder

=WENN(A1=1;"In A1 steht eine 1";"In A1 steht jetzt keine 1")

 

Auch die Hilfe zu Excel ist sehr gut

mfg

Chris

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...