Jump to content
Stairway

LaTex

Recommended Posts

H.B.
Posted

Was sagt denn der Log?

 

Wenn ich pdflatex {datei} ohne weitere Parameter anstarte, lande ich im interaktiven Modus und kann jeden Fehler auf der Kommandozeile abarbeiten.

Sollte ein Paket fehlen, wird er auch mekkern, dann must du es jedoch separat einbinden und das System neu kompilieren.

Share this post


Link to post
Stairway
Posted

Hi ficoach,

 

ja, ich glaube es liegt an den Paketen. Gibt es denn im Netz ein Programm das sofort alle Pakete installiert ? Früher hat das TexCenter die fehlenden Pakete von selbst installiert... Weiss jetzt auch nicht warum das dieses Mal nicht der Fall ist.

 

Ansonsten lief ja vor der Neuinstallation alles einwandfrei, daher kann es ja eigentlich nur an den Paketen liegen. Auch wenn ich eine leere Datei nur mit Wörtern kompiliere geht alles einwandfrei.

 

Gehören die Pakete dann in den TexnicCenter oder Miktex Ordner ?

 

Gracias,

 

Stairway

 

P.S. Log poste ich heute Abend, bin grad nicht daheim.

Share this post


Link to post
Stairway
Posted

Also hier eine der Fehlermeldungen im Log:

 

"I couln`t open file name "C:\User\....\Latex1.aux"

"Couldn`t find input index file C:\User\...\Latex1.idx"

 

Was kann man da machen ?

Share this post


Link to post
Stairway
Posted · Edited by Stairway

Okay, habe es gerade nochmal ausprobiert.

 

Wenn ich eine normale Datei erstelle, dann geht alles:

 

\documentclass[a4paper, 11pt]{article}

\begin{document}
Ich bin ein Text.
\end{document}

 

Füge ich nun aber ein Paket ein,

 

 

\documentclass[a4paper, 11pt]{article}
\usepackage{ngerman}
\begin{document}
Ich bin ein Text.
\end{document}

 

dann funktioniert es nichtmehr.

 

Fehlermeldungen:

 

post-6191-1268677827,31_thumb.jpg

 

 

Bin jetzt nur ratlos was ich dagegen machen soll...

 

(die .tex Datei heisst hier "Einarbeiten")

Share this post


Link to post
H.B.
Posted

Was rufst du denn auf?

 

Das Program "makeindex" versucht einen Index zu erstellen, findet aber keine Input-Datei. (Genauso, wie bibtex keine Referenzen findet)

Die Zusatzprogramme muss man doch gar nicht anstarten, wenn man solche Dinge nicht macht.

 

Gibt es bei dir kein Programm namens "pdflatex"?

Das macht nichts weiter, als PDF-Dateien aus tex-input. Ohne SchnickSchnak.

 

Vielleicht kannst du ja irgendwo einstellen, was alles aufgerufen werden soll.

 

 

Hast du schon mal "texhash" ausgeführt? Vielleicht sind noch einige Zeiger "verbogen".

Die Windows-Version sollte sich nicht sehr von der Unix-Version unterscheiden.

 

Ansonsten: Einfach das TexLive nochmal installieren, vorher vielleicht mal die Platte putzen.

Share this post


Link to post
Stairway
Posted · Edited by Stairway

Hey,

 

Was rufst du denn auf?

 

Ich habe den oben angegeben Quelltext und will daraus eine PDF Datei machen zum anschauen.

 

Das Program "makeindex" versucht einen Index zu erstellen, findet aber keine Input-Datei. (Genauso, wie bibtex keine Referenzen findet)

Die Zusatzprogramme muss man doch gar nicht anstarten, wenn man solche Dinge nicht macht.

 

Ich weiss nicht warum das gestartet wird...

 

Gibt es bei dir kein Programm namens "pdflatex"?

Das macht nichts weiter, als PDF-Dateien aus tex-input. Ohne SchnickSchnak.

 

Okay, das wäre ja klasse. Muss ich mir mal runterladen.

 

€: Habe mir das pdflatex gerader runtergeladen - ist das wieder irgendein alternatives Programm ohne .exe Datei ? Habe jetzt bei 3 Anbietern das Teil runtergeladen und finde keine ausführbare Datei... ich verzweifel noch mit diesem Latex,...

 

Hast du schon mal "texhash" ausgeführt? Vielleicht sind noch einige Zeiger "verbogen".

Die Windows-Version sollte sich nicht sehr von der Unix-Version unterscheiden.

 

Wie ruft man das denn auf ?

 

Ansonsten: Einfach das TexLive nochmal installieren, vorher vielleicht mal die Platte putzen.

 

Ist TexLive soetwas wie TechnixCenter ?

 

Grüße

Share this post


Link to post
H.B.
Posted

Pdflatex sollte eigentlich in deiner Distribution enthalten sein.

 

Ich kenne mich leider überhaupt nicht mit Windows aus. Wenn ich mich recht entsinne, gibt es so etwas, wie eine Konsole, unter W2k konnten man die mit "run command; cmd" aufrufen.

Dort kannst du dann in das Arbeitsverzeichnis wechseln und den Befehl "pdflatex <datei>" eingeben.

"texhash" müsste auch auf dieser Ebene funktionieren. Eventuell musst du ins Latex-Root-Verzeichnis wechseln, wenn kein Pfad gelegt wurde.

 

Ich vermute, das die Philosophie von Latex in einer Windows-Umgebung immer wieder "aneckt".

 

So sieht das übrigens bei mir aus:

tux:~/dokumente/marktanalyse> pdflatex main.tex
This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
%&-line parsing enabled.
entering extended mode
(./main.tex
LaTeX2e <2005/12/01>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, german-x-2008-06-18, ngerman-x-2008-06-18, german, ngerman, loaded.

(/usr/share/texmf/tex/latex/koma-script/scrartcl.cls
Document Class: scrartcl 2009/04/03 v3.03a KOMA-Script document class (article)

(/usr/share/texmf/tex/latex/koma-script/scrkbase.sty
(/usr/share/texmf/tex/latex/koma-script/scrbase.sty
(/usr/share/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/share/texmf/tex/latex/koma-script/scrlfile.sty
Package scrlfile, 2009/03/25 v3.03 KOMA-Script package (loading files)
                 Copyright (C) Markus Kohm

))) (/usr/share/texmf/tex/latex/koma-script/tocbasic.sty)
(/usr/share/texmf/tex/latex/koma-script/scrsize10pt.clo)
(/usr/share/texmf/tex/latex/koma-script/typearea.sty
Package typearea, 2009/04/03 v3.03a KOMA-Script package (type area)
                 Copyright (C) Frank Neukam, 1992-1994
                 Copyright (C) Markus Kohm, 1994-


Package typearea Warning: Bad type area settings!
(typearea)                The detected line width is about 31%
(typearea)                larger than the heuristically detected line width.
(typearea)                You should e.g. decrease DIV, increase fontsize
(typearea)                or change papersize.

)) (../shared/preamble.tex (/usr/share/texmf-dist/tex/latex/base/inputenc.sty
(/usr/share/texmf-dist/tex/latex/base/utf8.def

 

Da wird schön erklärt, wo es haken könnte .... falls mal etwas schief läuft.

Share this post


Link to post
Stairway
Posted

Okay,

 

ist sicher nett von dir gemeint, aber ich versteh' nur Bahnhof... Selbst für TexLive gibt es keinen normalen Download...

 

Ich verstehe einfach nicht, warum es plötzlich nichtmehr funktioniert. verdammt.

Share this post


Link to post
neysee
Posted

Fehlermeldungen:

 

post-6191-1268677827,31_thumb.jpg

 

GUI framework can't be initalized.

Da klingelt es doch leise bei mir:

 

Siehe hier

Share this post


Link to post
Stairway
Posted

Okay, hab sämtliche Pakete installiert, nun scheint es wieder zu gehen. Danke für die Hinweise.

Share this post


Link to post
Stairway
Posted

Warum macht es mir denn immer die Formatierung kaputt sobald ich ein \delta einbaue ? Kann danach weder normal weiterschreiben noch z.B. einen Satz mit \delta (Dreieck) in zentrierter Form schreiben. Wie kann man das lösen ?

Share this post


Link to post
gebe_nix
Posted · Edited by gebe_nix

Bin mir nicht ganz sicher, ob ich das Problem verstehe, aber ich würde \delta nur im Mathemodus benutzen.

 

Also $\delta$ für ein kleines Delta und $\Delta$ für ein großes Delta (Dreieck). Für eine abgesetzte Formel

 

\[

\Delta = G - V

\]

 

oder $$ .... $$.

 

Edit: Vielleicht solltest Du mal den entsprechenden Quelltext posten.

 

Mir ist eben noch die Idee gekommen, dass Du vielleicht in einer Formel normalen Text schreiben willst. Das geht so:

 

\[

\Delta \textnormal{ Hier soll jetzt normaler Text stehen. }

\]

 

Abstand zwischen Elementen in einer Formel mit \, \; oder \quad, \qquad.

Share this post


Link to post
Stairway
Posted · Edited by Stairway

Bin mir nicht ganz sicher, ob ich das Problem verstehe, aber ich würde \delta nur im Mathemodus benutzen.

 

Also $\delta$ für ein kleines Delta und $\Delta$ für ein großes Delta (Dreieck). Für eine abgesetzte Formel

 

\[

\Delta = G - V

\]

 

oder $$ .... $$.

 

Edit: Vielleicht solltest Du mal den entsprechenden Quelltext posten.

 

Mir ist eben noch die Idee gekommen, dass Du vielleicht in einer Formel normalen Text schreiben willst. Das geht so:

 

\[

\Delta \textnormal{ Hier soll jetzt normaler Text stehen. }

\]

 

Abstand zwischen Elementen in einer Formel mit \, \; oder \quad, \qquad.

 

Hi, folgender Text soll geschrieben werden:

 

\begin{center}

Jahresüberschuss \\ + Abschreibungen \\ + Rückstellungen \\ – \Delta Umlaufvermögen

\end{center}

 

Sprich, jede dieser Positionen untereinander und mittig. Das Delta ist im letzten Satz. Wenn ich das so kompiliere setzt es die letzte Zeile allerdings nichtmehr mittig.

Share this post


Link to post
neysee
Posted

\Delta geht halt nur im math-Mode, also wird implizit in diesen Modus geschaltet, begleitet von einer Latte Fehlermeldungen.

 

Man könnte es natürlich einfach durch $\Delta$ ersetzen, wirklich prickelnd ist das aber nicht, im Textmode ist das - ein Bindestrich und kein mathematisches Minus, die Abstände sind nicht toll etc.

 

Ich würde mit \usepackage{amsmath} eine der beiden Varianten

\begin{center}
Jahresüberschuss \\ ${} + \text{Abschreibungen}$ \\ ${} + \text{Rückstellungen}$ \\ ${} - \Delta\text{Umlaufvermögen}$
\end{center}

\begin{gather*}
\text{Jahresüberschuss} \\ {} + \text{Abschreibungen} \\ {} + \text{Rückstellungen} \\ {} - \Delta\text{Umlaufvermögen}
\end{gather*}

verwenden, bevorzugt die zweite.

Share this post


Link to post
gebe_nix
Posted · Edited by gebe_nix

Nutze eine align-Umgebung, dann kannst Du die Position jeweils mit einem "&" als Tabulator markieren.

 

Also ungefähr so

 

\begin{align*}

& \text{Jahres\"uberschuss} \\

+ & \text{Abschreibungen} \\

- & \Delta

\end{align*}

 

Dann sollte es ganz vernünftig aussehen. Das Ganze ist dann halt im Mathemodus und daher muss der normale Text mit \text bzw \textnormal geschrieben werden.

Share this post


Link to post
Stairway
Posted

Perfekt! Danke euch zwei!

Share this post


Link to post
Stairway
Posted · Edited by Stairway

Ich schon wieder... Also das Programm hat ja schon so seine Macken.

 

Anscheinend kommt es nicht damit zurecht, wenn man in der equotion Umgebung Umlaute verwendet. Weiss jemand wie man das umgehen kann ?

 

\begin{equation}

\frac{a}{bs} = \frac{c}{d} = z

\end{equation}

 

 

Funktioniert!

 

 

\begin{equation}

\frac{ü}{ö} = \frac{t}{z} = x

\end{equation}

 

Geht nicht!

 

€: Sorry für die vielen Fragen: Ein Leerzeichen in einer Formel geht wie ?

Share this post


Link to post
Sladdi
Posted

Anscheinend kommt es nicht damit zurecht, wenn man in der equotion Umgebung Umlaute verwendet. Weiss jemand wie man das umgehen kann ?

 

Hi,

Umlaute kann man sich im Mathemodus nur zusammenbasteln, z.B. ein "ö" durch \stackrel{..}{o}. Bei einem "ß" hast Du jedoch verloren.

 

 

Sorry für die vielen Fragen: Ein Leerzeichen in einer Formel geht wie ?

 

Da gibt es verschiedene, je nach dem Abstand. Ich benutze "\,".

 

Gruß

Sladdi

Share this post


Link to post
xolgo
Posted

\begin{equation}

\frac{ü}{ö} = \frac{t}{z} = x

\end{equation}

 

Ein Umlaut als Formelzeichen ist auch eher ungewöhlich. Punkte benutzt man doch für Zeitableitungen ;)

Sofern Du es - was ich begrüßen würde - nicht als Formelzeichen sondern als Text benötigst, hilft das schon genannte \text{ü}.

Share this post


Link to post
Stairway
Posted

\begin{equation}

\frac{ü}{ö} = \frac{t}{z} = x

\end{equation}

 

Ein Umlaut als Formelzeichen ist auch eher ungewöhlich. Punkte benutzt man doch für Zeitableitungen ;)

Sofern Du es - was ich begrüßen würde - nicht als Formelzeichen sondern als Text benötigst, hilft das schon genannte \text{ü}.

 

Ja, da soll dann quasi stehe: Jahresüberschuss / Eigenkapital = EKR , werde das morgen mit der Text Funktion ausprobieren.

Share this post


Link to post
Sladdi
Posted

Ein Umlaut als Formelzeichen ist auch eher ungewöhlich. Punkte benutzt man doch für Zeitableitungen ;)

 

Hi,

 

im Index einer Größe kann ein Umlaut aber durchaus vorkommen. Mit der von Dir vorgeschlagenen Variante würde der Umlaut nicht kursiv, sondern normal geschrieben werden.

 

Gruß

Sladdi

Share this post


Link to post
gebe_nix
Posted

Der Befehl lautet \"u für ein "ü" und \ss für ein "ß". Danach braucht man ggf. ein erzwungenes Leerzeichen mit ~.

 

Alternativ die Pakete

\usepackage[german]{babel}

\usepackage[T1]{fontenc}

\usepackage[latin1]{inputenc}

einbinden dann sollte LaTex die auch so erkennen. (Kann aber sein, dass das im Mathemodus nicht der Fall ist.) Weil im Mathemodus immer kursiv geschrieben wird und praktisch ohne Abstände, sollte man normalen Text sowieso immer in \text{...} schreiben.

 

Leerzeichen im Mathemodus je nach Größe \,, \; oder \quad, \qquad. Man kann auch mehrere kombinieren.

Share this post


Link to post
Schinzilord
Posted

Funktioniert im Mathemodus dies?

\begin{equation}

 

3 \cdot x^2 = \text{ \em{äöüöäöü} }

 

\end{equation}

Share this post


Link to post
xolgo
Posted

Ein Umlaut als Formelzeichen ist auch eher ungewöhlich. Punkte benutzt man doch für Zeitableitungen ;)

im Index einer Größe kann ein Umlaut aber durchaus vorkommen. Mit der von Dir vorgeschlagenen Variante würde der Umlaut nicht kursiv, sondern normal geschrieben werden.

 

Das (normal und nicht kursiv) ist meiner Meinung nach auch die korrekte Formatierung für einen Index, der ein Wort und kein Formelzeichen ist.

Share this post


Link to post
Stairway
Posted

Guten Tag, gibt es eine einfache Möglichkeit in Latex den eigentlichen Text auf 2/3 der Seite zu schreiben und in einer Leiste rechts daneben (1/3 der Seite) Platz für Kommentare oder kurze Zusammenfassungen zu lassen ? Müsste mit Boxen gehen, oder ? Falls jemand ein Template hat oder so wäre das klasse ;)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...