Jump to content
Bennerich

Portfolio Performance - Mein neues Programm

Recommended Posts

ImperatoM
Posted

Einen kleinen Verbesserungsvorschlag habe ich:

Wenn man ein Wertpapier kauft, ohne dass Kurse hierfür eingegeben werden, wird es mit einem Wert von null Euro bemessen, als ob man einen totalen Verlust gemacht hätte. Stattdessen sollte von PP der Kaufwert angenommen werden solange keine anderen Kurse existieren.

 

 

Hallo Bennerich, ich musste meine Festplatte umziehen und habe PP neu installiert. Jetzt funktionieren die Kuchencharts nicht mehr und die "eckigen" Charts sind nur noch einfarbig.

Was mach ich falsch?

 

Gute Frage, ich erlebe gerade das gleiche. Java, DirectX und Eclipse sind installiert, vermutlich ist es ein weiteres dieser "Addons", das fehlt. Ich komme aber auch nicht auf das richtige.

Share this post


Link to post
Der Heini
Posted

Problem Arero Fond (ISIN LU0360863863): Wie bekomme ich da die historischen Kurse rein? Über Yahoo geht es ja leider nicht. Mit einer URL von onvista hab ichs auch nicht hinbekommen oder mich mal wieder zu doof angestellt.

http://www.onvista.d...21984&RANGE=60M

 

(Methode: hier beschrieben)

 

Vielen Dank, hat funktioniert. thumbsup.gifw00t.gif

Share this post


Link to post
Bennerich
Posted

Hallo Bennerich, ich musste meine Festplatte umziehen und habe PP neu installiert. Jetzt funktionieren die Kuchencharts nicht mehr und die "eckigen" Charts sind nur noch einfarbig.

Was mach ich falsch?

Gute Frage, ich erlebe gerade das gleiche. Java, DirectX und Eclipse sind installiert, vermutlich ist es ein weiteres dieser "Addons", das fehlt. Ich komme aber auch nicht auf das richtige.

 

Für die Kuchengrafik verwende ich eine HTML5 Bibliothek - DirectX sollte eigentlich nicht benötigt werden. Aber es braucht eine aktuelle Version des Internet Explorers. Dabei ist es egal ob Ihr Chrome oder Firefox zum Browsen verwendet - als embedded Browser kann PP nur den Internet Explorer nutzen. Ist der Internet Explorer aktuell? Und wenn ja welche Version? (Meine Virtuelle Maschine mit Windows 10 funktioniert gerade nicht mehr - ich kann das nicht ausprobieren).

 

Was meinst Du mit "eckigen" Charts? Die Baumkarte (tree map) bei den Klassifizierungen? Da hat sich das Verhalten leicht geändert wenn man unklassifizierte Wertpapiere hat. Wenn Du mit einem (normalen) Linksklick auf ein Wertpapier einen Ebene nach unten navigierst, kommen dann wieder Farben?

Share this post


Link to post
Bennerich
Posted

In dieser Beispieldatei hat es zwei Konten: CHF und USD. Ich habe eine Umbuchung von 1000 Fr. auf das USD-Konto, zum tagesaktuellen Umrechnungskurs aus deiner EZB-Datenbank angelegt..

Wenn ich nun in der Ansicht Stammdaten/Konten/Umsätze die Buchung editiere, indem ich durch Doppelklick in der Spalte Notiz eine Anmerkung hinzufüge, dann ändert PP die Buchung zu einem Umrechenkurs von 1:1. Der Wechselkurs bleibt zwar korrekt angegeben, aber aus 1000 Fr. werden 1000 USD.

 

Ooops. :blushing: Vielen Dank für super nachvollziehbare Fehlerbeschreibung. Ist gefixt, kommt mit der nächsten Version. Bis dahin die Notizen nicht in der Tabelle per Doppelklick editieren sondern per Rechtsklick "Editieren...". Es betrifft das "inline editing" - also wenn man per Doppelklick in eine Tabelle den Wert ändert - und Währungen im Spiel sind.

 

Wenn als Wechselkurs ein Wert <0 eingetippt wird, kann PP nicht mehr weiterrechnen. Wenn allerdings zu einem bestimmten Datum der Wechselkurs automatisch <0 aufgeführt wird, dann rechnet PP sehrwohl, und der Wechselkurs lässt sich dann sogar editieren.

 

Auch da muss ich wohl noch mal ran. Der Wechselkurs darf eigentlich nicht negativ werden. (Was heißt ein negativer Wechselkurs auch? Für 100 Euro zahle muss ich dafür auch 90 Dollar zahlen?!?) Darum erlaubt der Dialog keine negative Wechselkurse zur Eingabe. Anscheinend werden die aber nicht geprüft, wenn die für ein bestimmtes Datum negativ sind.

Share this post


Link to post
ImperatoM
Posted

Für die Kuchengrafik verwende ich eine HTML5 Bibliothek - DirectX sollte eigentlich nicht benötigt werden. Aber es braucht eine aktuelle Version des Internet Explorers. Dabei ist es egal ob Ihr Chrome oder Firefox zum Browsen verwendet - als embedded Browser kann PP nur den Internet Explorer nutzen. Ist der Internet Explorer aktuell? Und wenn ja welche Version? (Meine Virtuelle Maschine mit Windows 10 funktioniert gerade nicht mehr - ich kann das nicht ausprobieren).

 

Was meinst Du mit "eckigen" Charts? Die Baumkarte (tree map) bei den Klassifizierungen? Da hat sich das Verhalten leicht geändert wenn man unklassifizierte Wertpapiere hat. Wenn Du mit einem (normalen) Linksklick auf ein Wertpapier einen Ebene nach unten navigierst, kommen dann wieder Farben?

 

Bei mir ist der IE 8.0.7601 (64 bit). Müsste ich im alten System eigentlich auch gehabt haben.

 

Die meisten Sachen funktionieren ganz normal (z.B: die Vermögensaufstellung und das Performance-Diagramm), aber einige wenige Seiten werden überhaupt gar nicht angezeigt, z.B.:

Vermögensaufstellung -> Bestände

oder eben die Tortendiagramme u.a. in Asset Allocation

 

Ziemlich komisch. Das Fehlerprotokoll generiert keine Meldung. Sieht wirklich so aus als müsste man noch irgendwas installieren, das zur Anzeige benötigt wird.

Share this post


Link to post
Birke
Posted · Edited by Birke
(Meine Virtuelle Maschine mit Windows 10 funktioniert gerade nicht mehr - ich kann das nicht ausprobieren).

Kein Windows-Nutzer? Ein vernünftiger Mensch ;-)

 

Ooops. :blushing: Vielen Dank für super nachvollziehbare Fehlerbeschreibung. Ist gefixt, kommt mit der nächsten Version.

Danke dir!

 

Der Wechselkurs darf eigentlich nicht negativ werden. (Was heißt ein negativer Wechselkurs auch? Für 100 Euro zahle muss ich dafür auch 90 Dollar zahlen?!?)

Da war ich jetzt ungenau bzw. falsch. Ich meinte natürlich einen Wechselkurs < 1 ... Sorry blushing.gif Das Problem beginnt, sobald ich den voreingestellten Wert zum Überschreiben markiere und eine Null eintippe.

Share this post


Link to post
slekcin
Posted

Ich habe gestern das Programm installiert und mein ETF Depot eingefügt. Ich habe mal eine etwas allgemeinere Frage und wie das Programm damit umgeht. Ich wollte demnächst das erste mal rebalancen und frage mich wie sich das ganze beim reinvestieren von Ausschüttungen verhält. Wenn ich einen ETF für 100€ gekauft habe, dieser 10€ Dividende ausgeschüttet hat (am ex Tag also nurnoch 90€ wert ist) und ich die 10€ wieder anlege wird mein Broker sagen dass ich insgesamt 110€ investiert habe, mein Depotwert aber nur 100€ beträgt. Meine Performance wäre also negativ obwohl sich der Depotwert nicht verändert hat. Vllt habe ich hier auch einen klassischen Anfänger Denkfehler. Ich hoffe ihr versteht was ich meine.

Share this post


Link to post
Birke
Posted

Noch präziser:

 

Erstelle eine Umbuchung zwischen zwei Konten unterschiedlicher Währung. Gib einen Betrag ein und markiere den voreingestellten Kurs zum Überschreiben. Tippe eine 0 und die Fehlermeldung erscheint: "Beim Festlegen des Werts trat ein Fehler auf." Die Fehlermeldung bleibt, auch wenn der Wechselkurs weiter editiert wird.

 

Mache dasselbe. Statt aber den Wechselkurs zu überschreiben, änderst du erst die Nachkommastellen. Wenn du anschliessend die 1 vor dem Komma durch eine Null ersetzt, kommt es nicht zur Fehlermeldung.

 

Es scheint also ein Problem zu sein, wenn im Feld Wechselkurs (vorübergehend) eine Null eingetragen ist. Vielleicht ein Div/0-Fehler?

Share this post


Link to post
Bennerich
Posted

Bei mir ist der IE 8.0.7601 (64 bit). Müsste ich im alten System eigentlich auch gehabt haben.

 

Die meisten Sachen funktionieren ganz normal (z.B: die Vermögensaufstellung und das Performance-Diagramm), aber einige wenige Seiten werden überhaupt gar nicht angezeigt, z.B.:

Vermögensaufstellung -> Bestände

oder eben die Tortendiagramme u.a. in Asset Allocation

 

Ziemlich komisch. Das Fehlerprotokoll generiert keine Meldung. Sieht wirklich so aus als müsste man noch irgendwas installieren, das zur Anzeige benötigt wird.

 

IE 8 ist auch ziemlich alt (von 2011). Vielleicht mal IE 11 installieren?

 

Nur die Kuchengrafiken werden aktuell mit dem eingebetteten Browser generiert. Bei älteren Versionen wird die D3.js Version nicht geladen, leider kann ich bei dem Browser auch nicht das Fehlerlog abgreifen. Darum steht nichts im Log. Ursprünglich wollte auch dem Weg schönere, interaktive Grafiken bauen. Aber das Ganze ist zu fragil.

 

Ich habe gestern das Programm installiert und mein ETF Depot eingefügt. Ich habe mal eine etwas allgemeinere Frage und wie das Programm damit umgeht. Ich wollte demnächst das erste mal rebalancen und frage mich wie sich das ganze beim reinvestieren von Ausschüttungen verhält. Wenn ich einen ETF für 100€ gekauft habe, dieser 10€ Dividende ausgeschüttet hat (am ex Tag also nurnoch 90€ wert ist) und ich die 10€ wieder anlege wird mein Broker sagen dass ich insgesamt 110€ investiert habe, mein Depotwert aber nur 100€ beträgt. Meine Performance wäre also negativ obwohl sich der Depotwert nicht verändert hat. Vllt habe ich hier auch einen klassischen Anfänger Denkfehler. Ich hoffe ihr versteht was ich meine.

 

Du erfasst die 10€ als Dividende - das wird nicht als externer (performanceneutraler) Mittelzufluss gerechnet. Das investierte Kapital ist weiterhin 100 €.

 

Die Performance-Rechnung an sich hängt im Detail von der Methode ab.

Der Interne Zinsfuß rechnet mit 100 € am Anfang und 100 € Depotwert am Ende (90 € Aktienwert + 10 € Dividende auf dem Konto). Das sieht nach 0 Euro aus.

In Deinem Fall sollte der TTWROR auf das selbe Ergebnis.

 

Es scheint also ein Problem zu sein, wenn im Feld Wechselkurs (vorübergehend) eine Null eingetragen ist. Vielleicht ein Div/0-Fehler?

 

Danke. Jetzt weiß ich wonach ich gucken muss.

Share this post


Link to post
NetMac
Posted · Edited by NetMac

@Bennerich

 

 

Hallo Bennerich

 

Ich habe gesehen das es keinen Import Vorlage für die 1822direkt gibt. Hast du zufällig Geplant diese mit aufzunehmen?

 

Gruß Florian

Share this post


Link to post
Mojo-cutter
Posted · Edited by Mojo-cutter

Hallo Bennerich, ich musste meine Festplatte umziehen und habe PP neu installiert. Jetzt funktionieren die Kuchencharts nicht mehr und die "eckigen" Charts sind nur noch einfarbig.

Was mach ich falsch?

 

 

Gute Frage, ich erlebe gerade das gleiche. Java, DirectX und Eclipse sind installiert, vermutlich ist es ein weiteres dieser "Addons", das fehlt. Ich komme aber auch nicht auf das richtige.

 

Für die Kuchengrafik verwende ich eine HTML5 Bibliothek - DirectX sollte eigentlich nicht benötigt werden. Aber es braucht eine aktuelle Version des Internet Explorers. Dabei ist es egal ob Ihr Chrome oder Firefox zum Browsen verwendet - als embedded Browser kann PP nur den Internet Explorer nutzen. Ist der Internet Explorer aktuell? Und wenn ja welche Version? (Meine Virtuelle Maschine mit Windows 10 funktioniert gerade nicht mehr - ich kann das nicht ausprobieren).

 

Was meinst Du mit "eckigen" Charts? Die Baumkarte (tree map) bei den Klassifizierungen? Da hat sich das Verhalten leicht geändert wenn man unklassifizierte Wertpapiere hat. Wenn Du mit einem (normalen) Linksklick auf ein Wertpapier einen Ebene nach unten navigierst, kommen dann wieder Farben?

 

Hallo Bennerich,

 

Kuchenchart: das Problem war ein veralteter IE (Vers. 8). Nach dem update auf IE11 funktioniert es wieder tatenlos.

Baumkarte: wie von dir berichtet: beim Anklicken erscheinen die Farben.

 

Also alles wieder in Ordnung. Vielen Dank.

Share this post


Link to post
ImperatoM
Posted

Auch bei mir ist nach dem Update auf IE11 alles wieder in Ordnung - danke :thumbsup:

Share this post


Link to post
Aktionaer
Posted

Hallo zusammen,

 

gibt es die Möglichkeit oder wird es in Zukunft die Möglichkeit geben P2P Kredite abzubilden?

 

Wenn ich z.B. bei Auxmoney, Lendico, Mintos etc. bin, würde ich gerne diese einzelnen Kredite in den Portfolio Performance eingeben. Auch wenn ein Kredit ausfällt usw.

 

Wäre super, da es ein Teil der Gesamtfinanzperformance ist. :-)

 

Viele Grüße

Share this post


Link to post
ImperatoM
Posted

gibt es die Möglichkeit oder wird es in Zukunft die Möglichkeit geben P2P Kredite abzubilden?

Wenn ich z.B. bei Auxmoney, Lendico, Mintos etc. bin, würde ich gerne diese einzelnen Kredite in den Portfolio Performance eingeben. Auch wenn ein Kredit ausfällt usw.

Wäre super, da es ein Teil der Gesamtfinanzperformance ist. :-)

 

Kredite, die Du vergibst, funktionieren wie Anleihen, die Du kaufst. Deren Implementierung ist geplant. Dann kannst Du auch die Kredite abrechnen.

Share this post


Link to post
Hasenhirn
Posted

Alternativ: Einzelne Kredite, die du vergibst, funktionieren wie einzelne Sparkonten, nur dass du eben nicht einer Bank dein Geld leihst, sondern einem privaten Schuldner. Der Kreditbetrag ist deine Einlage, Schuldzinsen sind Guthabenzinsen, Tilgungen sind Entnahmen/Auszahlungen. Das kann PP heute schon. (Habe allerdings keine Ahnung, wie man Kreditausfälle performanztechnisch darstellen würde.)

 

Grüße, H.

Share this post


Link to post
hamsta
Posted · Edited by hamsta

To whom it may concern...

 

Die GICS-Klassifizierung hat sich geändert.

- Neuer Sektor "Real Estate".

- Trennung zwischen mREITs (bleiben bei Financials) und eREITs (neuer Sektor).

 

 

Was, wie & warum:

Guggsdu hier

Share this post


Link to post
civis
Posted

To whom it may concern...

 

Die GICS-Klassifizierung hat sich geändert.

- Neuer Sektor "Real Estate".

- Trennung zwischen mREITs (bleiben bei Financials) und eREITs (neuer Sektor).

Danke für den Hinweis! thumbsup.gif

 

Viele Grüße

civis

Share this post


Link to post
Birke
Posted

Hi

 

Es gibt Fonds mit mehreren Währungs-Tranchen. Wenn ich bei einem Fonds nur die historischen Werte für die USD-Tranche im Internet finde (z.B. LU0340285161), aber CHF-Anteile kaufen möchte, überlege ich mir folgende Lösung:

  • Ich lege das Wertpapier in USD an.
  • Ich kaufe die Anteile in CHF und nehme als Wechselkurs einfach den Unterschied zwischen USD- und CHF-Kurs.

Übersehe ich etwas in Bezug auf die Performance-Berechnungen?

 

Oder gäbe es eine saubere Lösung?

 

 

 

Share this post


Link to post
Birke
Posted

Huuu, bei Onvista kann ich für die historischen Kurse den Börsenplatz wählen w00t.gif

 

Vergesst also meine Frage und verzeiht die Zeit, die ich euch damit gestohlen habe!

 

Birke

 

 

PS: Dass die Kurse bei unterschiedlichen Quellen voneinander abweichen, ist ja scheinbar normal....

Share this post


Link to post
civis
Posted

Huuu, bei Onvista kann ich für die historischen Kurse den Börsenplatz wählen w00t.gif

Bei finanzen.net auch (SIX Swiss Exchange). thumbsup.gif

 

Viele Grüße

civis

Share this post


Link to post
snekker77
Posted

Hallo Bennerich,

 

erstmal Danke für das tolle Programm.

 

Ich habe leider ein kleines Darstellungsproblem. Bei mir wird in der Spalte Bestand nichts angezeigt.

Der Tooltip funktioniert aber (siehe Bild). An meiner Datenbank sollte es nicht liegen, da auch die Beispiele

Kommer und DAX das selbe Verhalten zeigen.

Ich habe auch schon alles mögliche in der Spaltenansicht versucht (Spalten ab- und zuschalten,

Spalten verschieben sowie zurücksetzen). Auch die GUI habe ich schon zurückgesetzt. Leider kein Erfolg.

Kannst du dir das erklären?

 

post-34836-0-80931500-1475919742_thumb.jpg

 

Zur Info: Ich nutzte Ubuntu 16.04.

 

Viele Grüße

Share this post


Link to post
Bennerich
Posted

Ich habe leider ein kleines Darstellungsproblem. Bei mir wird in der Spalte Bestand nichts angezeigt.

 

[...]

 

Auch die GUI habe ich schon zurückgesetzt. Leider kein Erfolg.

Kannst du dir das erklären?

 

Das sieht mir nach eine GTK Problem aus (Ich nutze Eclipse mit SWT. Und SWT nutzt die nativen Window Toolkits).

 

Allein, ich kann nicht sagen was genau dazu führt. Eigentlich instruiere ich PP GTK2 zu nutzen (und nicht GTK3 was glaube ich mit Ubuntu 16.04 Default ist).

Eine Suche nach ähnlichen Fehlern hat mir jetzt auch nichts gesagt.

Ich würde mal probieren ob Du a) mit einem anderem Theme die Daten siehst. Oder ob Du die GTK2 Libraries nach installieren kannst.

Share this post


Link to post
snekker77
Posted

Das sieht mir nach eine GTK Problem aus (Ich nutze Eclipse mit SWT. Und SWT nutzt die nativen Window Toolkits).

 

Allein, ich kann nicht sagen was genau dazu führt. Eigentlich instruiere ich PP GTK2 zu nutzen (und nicht GTK3 was glaube ich mit Ubuntu 16.04 Default ist).

Eine Suche nach ähnlichen Fehlern hat mir jetzt auch nichts gesagt.

Ich würde mal probieren ob Du a) mit einem anderem Theme die Daten siehst. Oder ob Du die GTK2 Libraries nach installieren kannst.

 

Hallo Bennerich,

 

Danke erstmal für deine Antwort. Leider haben die von dir genannten Vorschläge keine Abhilfe gebracht. Weder das Wechseln des

Theme noch die Installation der GTK2-Pakete brachte eine Verbesserung. Ich habe auch mit verschiedenen Schriftarten und -größen gespielt.

Brachte alles nix.

 

Was mich wundert ist, dass es nur die Spalte "Bestand" betrifft. Alle anderen Spalten werden ja korrekt angezeigt. Der einzige Unterschied zu den anderen

Spalten (abgesehen von der Spalte "Name" ) ist, dass beim Bestand ein Tooltip angezeigt wird.

 

Es ist jetzt prinzipiell auch nicht allzu tragisch, ich kann damit leben. Es gibt sicherlich wichtigere Themen für dich smile.gif.

 

Viele Grüsse

Share this post


Link to post
Bennerich
Posted

Danke erstmal für deine Antwort. Leider haben die von dir genannten Vorschläge keine Abhilfe gebracht. Weder das Wechseln des

Theme noch die Installation der GTK2-Pakete brachte eine Verbesserung. Ich habe auch mit verschiedenen Schriftarten und -größen gespielt.

Brachte alles nix.

 

Was mich wundert ist, dass es nur die Spalte "Bestand" betrifft. Alle anderen Spalten werden ja korrekt angezeigt. Der einzige Unterschied zu den anderen

Spalten (abgesehen von der Spalte "Name" ) ist, dass beim Bestand ein Tooltip angezeigt wird.

 

Es betrifft nur die Spalte "Bestand" weil die anders gerendert wird ("OwnerDrawLabel").

Ich hatte genau dieses Problem schon mal hier: https://github.com/buchen/portfolio/issues/385

Damals hat ein Flag in der PortfolioPerformance.ini Datei für Abhilfe gesorgt. Poste doch (da) mal wie Deinen INI Datei aussieht.

Share this post


Link to post
snekker77
Posted

Es betrifft nur die Spalte "Bestand" weil die anders gerendert wird ("OwnerDrawLabel").

Ich hatte genau dieses Problem schon mal hier: https://github.com/b...olio/issues/385

Damals hat ein Flag in der PortfolioPerformance.ini Datei für Abhilfe gesorgt. Poste doch (da) mal wie Deinen INI Datei aussieht.

 

Ich habe den Inhalt der Datei PortfolioPerformance.ini mal unter dem Link https://github.com/b...olio/issues/385 gepostet.

 

Was ich allerdings noch rausgefunden habe (siehe http://https://bugs....g.cgi?id=492371):

 

Setze ich die Variable

 

export SWT_WEBKIT2=1

 

und starte dann PortfolioPerformance, wird die Spalte Bestand korrekt angezeigt. Ich erhalte dann allerdings noch ein

paar Fehlermeldungen.

 

 

(Portfolio Performance:5686): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

 

(Portfolio Performance:5686): GLib-CRITICAL **: Source ID 566 was not found when attempting to remove it

 

(Portfolio Performance:5686): GLib-CRITICAL **: Source ID 666 was not found when attempting to remove it

 

(Portfolio Performance:5686): GLib-CRITICAL **: Source ID 759 was not found when attempting to remove it

 

Die erste Warnung habe ich auch so, die anderen 3 kommen erst nach dem Setzen der Variable.

 

Viele Grüsse

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...